×

[PR]この広告は3ヶ月以上更新がないため表示されています。
ホームページを更新後24時間以内に表示されなくなります。

【トラブルのお部屋!?】

 

トラブルのお部屋です。今までに経験した数々のトラブルとその対処法、未解決の現状を列記し、皆様の参考&私の手助けになることを期待するページです。我ながらムシが良いですねー (^。^)

‘同じトラブルを抱えてうーん’の方、‘もう解決したよ’‘こうすれば治るよ’という方、いらっしゃいましたら是非 VAIO・PC BBS にカキコして下さい。宜しくお願いします。

では早速いってみましょう。

なお、下表の‘発生頻度’はトラブル未解決状態でのトラブル発生頻度を、‘危険度’はそのトラブルが解決しない状態の場合、PCの運用にどの程度問題が発生するかを、それぞれ個人的主観に基づいた感覚レベルで表現したものです。

RX62改 グラボ増設後発生? 発生頻度:20% 危険度: 解決済?
休止状態に入れない
RX62改用のモニタ交換に伴い、グラボ増設を行って以降、スタンバイが不安定になったのでGigaPocketの録画予約にはスタンバイではなく休止状態(ハイバネーション)を使用するようになったんですが・・・
数回に1回程度失敗するんですよねぇ・・・ 「失敗」というのは、休止状態に入ろうとすると、そのまま一度画面が暗転するんですが、数秒後に元の通りデスクトップ画面が表示され、しかもタスクトレイにこんなエラーが・・・
Windows-システムエラー
システムリソースが不足するため、APIを終了できません。


で、この直後はもちろん再度休止状態に入ることは出来ないんですよね。そもそもこの状態でコントロールパネルを覗くと、休止状態は無効になっちゃってますし(T_T) まあ、一度再起動すればもとの状態には戻るんですけどね・・・

という訳で、WEB上をさまよった結果、どうもメモリを大量に積んだ場合のOSそのもののバグっぽい情報をGETしました。
1GB 以上のRAMを搭載したコンピュータの休止に関する問題(KB330909)
条件としては、
・コンピュータに1GB以上のRAMが搭載されている。
・コンピュータで複数のプロセスが動作中で、負荷の高い状態になっている。

という環境の下で発生する可能性があり、そのためのパッチも上記URLからダウンロードできるんです。‘み’のRX62改はここで紹介しているようにメモリを2GB搭載していますし、実際にメモリを500〜600MB使用した状態だとハイバネーション出来なくなっているようだったので、これを当てれば・・・と思ったのも束の間。良く良く読むと、この修正パッチはXP-SP2に含まれているんだとか・・・ 今回のトラブルはXP-SP2環境下で発生しているので、このパッチでは役に立たないことに・・・

で、更に情報を漁っていくと・・・
ときどきコンピュータは hibernate 、 Windows XP Service Pack 2、 Windows XP Tablet PC Edition 2005 または Windows XP Media Center Edition 2005 に「 十分 システム リソース存在に完了 API」エラー メッセージを表示します。(KB909095)
という意味不明な技術情報を発見。これはSP2も対象に含まれていますし、条件としては
・コンピュータが 1 GB(GB)または複数の RAM を使用する場合、通常この問題が発生。
となっていますので、今度こそ・・・ と思ったら、どうやら正式公開していないパッチのようで、WEBからはダウンロードできませんでした。次回のSP3に含まれるパッチになるようですが、現時点ではMSのサポートにTELをしてパッチをもらうことになるんだそうで・・・う〜ん、メンドクサイ(^_^;)

という訳で、いよいよ解決へ〜

1.マイクロソフトサポート契約センターに電話
 営業時間 9:30 - 12:00   13:00 - 19:00 ( 土日祝日、弊社指定休業日を除く )   電話番号 0120-17-0196
 番号こそフリーダイヤルですが、この時間はなんとも殿様チックですねぇ・・・
 案の定、TELが繋がってからオペレーターに繋がるまでかなり待たされました(^_^;)
2. 趣旨に合った番号を押す
  「〜のお客様は1とシャープを押してください」とかいうやつですね。
3.担当の人がTELに出るので、「修正プログラムが欲しい」旨をアピール
4.技術情報(KB)の番号を聞かれる。
  →上記「KB909095」を伝える。
5.広域に渡るテストを行っていないものである点や、他の問題が発生する可能性、問題が解決しない可能性が ある点、パッチによってはアンインストール出来ないものもあること・・・などを説明され、それでも良いか確認 される。技術員による有償サポートも勧められる。
  →勿論了解。無償のパッチだけが欲しいと主張。
6. OSのバージョンなどを聞かれる
  → XP Professionalと回答。
7. 電話番号、氏名、メールアドレスを聞かれる(個人情報保護関連で目的とかを説明されたような気も)
  → 回答。電話終了
8. しばらくして(30分ぐらい)上記メールアドレスにで修正プログラムのあるURLと、回答時に必要なパスワード  が送付される。
9. 「252708_JPN_i386_zip.exe(2560KB)」をダウンロードし、上記パスワードで解凍。
  パスワードは1週間で変わるそうなので、メールをもらったら直ぐにDLしておきましょう。
10.解凍して出来た「WindowsXP-KB909095-x86-JPN.exe(2475KB)」を実行。
11.PCを再起動。

正式公開していないパッチということで多少心配はしていたんですが(実際にパッチを当てる直前のCドライブはバックアップしておきましたし)、既にパッチを当ててから数ヶ月使用していますが、‘み’の環境では特に問題は発生していません。取り合えず解決ですかね〜(^_^;)
(2006.06.20)
   

RX62改 NISインストール後再発 発生頻度:99% 危険度: 回避済??
タスクトレイに予約マネージャーのアイコンが表示されない。(再発!!)
Winny関係で情報流出するニュースが非常に多くなってきたので、ちょっとセキュリティを見直そうなかなぁなどと思いつつ、年明けにビックカメラの福袋でGETしたNorton Internet Security 2006をインストールしてみたんですが・・・
下で解決(回避)したタスクトレイへの予約マネージャアイコン表示問題が再発してしまいました(T_T) しかも、今回はスタートアップのタイミングの調整ではどうにもアイコンが表示されません・・・
相変わらずアイコンが表示されないだけで録画予約などには全く問題がないのですが、どうにも気持ち悪いことこの上ないばかりか、今回はほぼ毎回予約マネージャーのアイコンが表示され無くなってしまいました・・・
という訳で、「Tray Icon Reviver」というフリーソフトを使って強制的にトレイアイコンを表示させることにしました。リンク先だけでは分かりにくいかと思いますので、窓の杜の紹介ページも参考にしてください。
このソフト、元々は「エクスプローラが再起動したような時に、消えたタスクトレイアイコンを復活させて操作可能
にする」のが主な機能のようですが、自動再表示が出来ない場合に、そのソフトを強制実行や強制再起動してアイコンを登録することも出来るので、今回はこれを活用することに。
実際にこのTray Icon Reviverをスタートアップに登録し、予約マネージャーを登録してみたんですが、残念ながらそのままでは予約マネージャーアイコンは表示されず(T_T) 仕方がないので、気になる時(ちゃんと録画できていることを確認しておきたい時とか)には、上で書いた強制実行をすることで何とか予約マネージャーアイコンを復活させることに成功しました。
取り合えずこんな形で予約マネージャーのアイコン表示は出来るようになったんですが、極まれにこのTray Icon Reviverのアイコン自体が表示されないこともあったりして・・・ どうにもタスクトレイ周りが不安定なんですよねぇ・・・ OS再インストールでもすれば復活するかなぁ・・・

(2006.05.18)
   

RX62改 Giga録画失敗後発生 発生頻度:30% 危険度: 対応済??
タスクトレイに予約マネージャーのアイコンが表示されない。
GigaPocketのタイマー録画予約に久しぶりに失敗しました。どうもスタンバイ状態から起動はしたものの、予約マネージャーが上手く動作しなかったみたいです。番組は撮り逃しましたが、Giga周りそのものはPC再起動で復活・・・したかに思えましたが、タスクトレイに予約マネージャーのアイコンが表示されません。

タスクマネージャーなどで確認するとReserveModule.exeは動いていますし、ショートカットとかで予約マネージャーを起動するとちゃんと画面が起動されるんですが、録画に入ったときにタスクトレイアイコンの色が変わったりしないと精神衛生上もよろしくないので、ちゃんとアイコンが表示されるようにしたいところです。
実はこのトラブル、Gigaに限った話ではなく、WinXPでは結構発生しているようです。WEBで検索した感じでは、Win-XPではタスクトレイアイコンへの登録に4秒以上かかると、登録がキャンセルされてしまうそうで、‘み’の場合は2つ下のトラブルにも書いたようにNorton Internet Security をPC立ち上げ時に起動させ、タスクトレイにそのアイコンを表示しているんですが、こっちが先に起動したりするとそれなりに時間が掛かるので、予約マネージャーの方がパスされてしまうことになっているようです。今回は録画失敗のときにこの辺がおかしくなってしまったようです。

で、対処方法ですが、各アプリの起動タイミングを変更することにします。BootVisで制御できればよかったんですが、現在は公開されていませんので、手動で制御。
マイコンピュータ〜管理〜サービスで不要なサービスを自動起動から手動起動に変更したり、msconfigから不要なスタートアップを吟味して消したり・・・ まあ、この辺は殆ど済ましていたので、結局変化は殆ど無かったんですが・・・ 更に、一番の原因になっているNISの自動起動設定を一度解除して再起動(危険なのでネットワークから外しておいた方が良いかも)し、もう一度自動起動設定にすることで、各ソフトの起動タイミングが変わった(要するに予約マネージャーの方がNISより先に起動する。アイコンも予約マネージャーが先:右に表示されます)ようで、無事にアイコンが表示されるようになりました。

まあ、これは100%の対処にはなっていないんので、タマにアイコンが表示されないこともあるんですけどね(^^;) 多分上記「4秒」をどこかレジストリを弄くって変更すればいいような気もしますが、そこまでの調べはつかなかったので、今回はこれでお茶を濁しています。どなたかいい方法ご存知無いですか〜〜??

(2005.01.26 記載)


BBSで優さんから「スターアップ制御フリーソフトを使ってはどうか?」というカキコを頂き、早速試してみました。色々と種類があるんですが、今回はカキコ頂いた方もお使いという「StartupEx」を使ってみることに。本当はスタートアップフォルダ内だけでなく、レジストリに書き込まれているソフト、特にNorton Internet Security(以下NIS)なども問題になるんですが、この辺を弄くるのはちょっと危険なのでガマンし、スタートアップフォルダ側の調整で対処してみます。今回問題になったのは予約マネージャーのアイコンなんですが・・・まずはStratupExを使い、予約マネージャー以外のスタートアップ項目を思いっきり遅延させて(7秒とかそんな感じ)みましたが、状況は変わらず。どうやらNISと予約マネージャーの両アイコンについて、タスクトレイへの登録タイミングがぶつかるとどちらか片方(大概は予約マネージャーなんですが、何度か試しているうちに稀にNISの方が表示されないこともありました・・・)が表示されないようです。現状ではNISに予約マネージャーが負けている感じでしょうか・・・ で、今度は予約マネージャーの起動も遅らせてみましたが、今度はNISが確実に表示されるものの、予約マネージャーはNG・・・ こうなると予約マネージャーを真っ先に起動し、その後にNISなどが起動するようにするしかないですねぇ
ってことで設定変更&再起動を何度となく繰り返し、「ほぼ」両方のアイコンが表示されるタイミングを見極めました。
ショートカット先のフルパスは
隠してあります。
なお、起動完了待ちの
設定などは特にしていません。
これはStartupExの設定画面ですが、予約マネージャーを最優先で起動させ、その後に間を置いて各種スタートアップを実施。最後にNISが起動するような感じです。この設定だと、セキュリティソフトが最後に起動するけどいいのか??とか、ごく稀にNISのアイコンが表示されないとか、・・・課題は残りますが、予約マネージャーアイコンはほぼ確実に表示されますし、どうしても気に入らなければ一度ログオフして再ログインすればちゃんと両アイコンが復帰してくれますので、最悪はこれでもいいかと・・・(^^;)
ってことで、取り合えず解決・・・かな??

(2005.02.20加筆)
   


RX62改 M/B交換後発生 発生頻度:50% 危険度: 対応済
SATA-HDDが認識されなくなることがある。
久しぶりにデカイトラブルです。しかも3重トラブル(^^;)
M/B交換以降HDDも交換しているんですが、どうもこのHDDの認識が悪いんです。SATA2コネクタに接続したMaxtorの「MXT-6Y200M0」なんですが、突然認識しなくなってOSごとフリーズすることが数回・・・
どうもOSの問題とも思えず、RX筐体をあけてチェックしてみると・・・電源コネクタ(200M0にはSATAタイプとIDEタイプと2系統の電源コネクタが用意されていますが、‘み’はIDE用の4pinコネクタを使用しています)が抜けかかっていました(^^;) どうやらHDD用のFANを設置したりしたときに緩んでしまったようです。早速しっかりと挿しなおしたのは言うまでも有りません。で、一見回復したかと思いきや・・・敢え無く再発・・・ コネクタそのものが緩くなっているのかと思いましたが、そんなことはなく・・・ ただ、なんとなく4本の電源ケーブルのうち1本が緩んでいるように思えたので、電源分岐ケーブルを新品に交換したところ・・・どうやら回復したようです。ってことでここまでの原因はケーブルの接続とケーブルそのものの問題による電源供給不安定ということで片付いたんですが・・・
しばらくしてから気が付きました。SATA-HDDは今SATA1の「6Y120M0」とSATA2の「6Y200M0」と2台接続しているんですが、200M0側に設定しているE・Fの両論理ドライブにアクセスすると、数秒間反応がないんです。タイムアウトする訳でもなく、フリーズするわけでもないんですが、起動して最初のアクセス時のみ異常に待たされるんですよね。2度目以降はOK・・・ う〜ん、これは・・・上の電源供給系でHDDをどこかおかしくしてしまったのかもしれません。よくよく考えれば2度目以降にちゃんとアクセスできる時点でハード系の問題ではないような気もするんですが、これまでの経緯から完全にハードを疑っていました。まずは電源コネクタ&SATAコネクタの接続確認、SATAケーブルの新品交換・・・いずれも効果なし。接続系の問題では無いようです。次にHDDのエラーチェック・・・これも全然問題なし。デフラグを掛けても効果なし(どちらのドライブも半分以上空き容量あり)。IDEコントローラやHDDそのものをデバイスマネージャから削除して再認識させても、ドライブレターを変えてもダメ・・・ 起動直後でも症状が発生するので熱暴走でもない・・・
ちょっとココまで来てかなり諦めの境地に達してきたんですが・・・(^^;) ふとあることに気が付きました。どちらのドライブもデータ中心に使用していたので、F1のTV中継を録画してTMPGEnc3.0XPressでVBRエンコした.m2vファイルや.AVIファイルなんかがルートに置いてある・・・これって結構容量を食いますし、.AVIってOSが中身を見に行くのでそれが含まれたフォルダ表示すると時間がかかることがあるはず・・・ いや、でも前からこういう使い方をしてきたし・・・ ん、m2vもAVIも関連付けが・・・ !!
そう、この手のファイルの関連付けを、最近 BS Playerに変更していたんです。日本語化も可能で操作性も悪くないので使っていたんですが、Verが1.0台になってからというもの初回の起動にやけに時間がかかるようになってしまっていて気になっていたんですよね。そう、正にコイツが悪さをしていたんです。関連付けを解除すると、無事に待たされること無くE・Fドライブにアクセスできるようになりました(^^) いや〜、一時はどうなることかと思いましたが・・・意外なところに落とし穴&解決策がありましたねぇ・・・今度はかなり悩みましたが、解決してよかったですぅ HDDクラッシュではなかったので余計な出費も掛かりませんでしたしね(^^;)

(2004.07.29 記載)
   

RX62 UPnP設定後発生 発生頻度:100% 危険度: 回避済
WinXPで、タスクトレイアイコンが表示されなくなる。
特に理由も無いんですが、思い立ったかのようにUPnPを有効にしてみました。ルーターの方は京セラMETEORの古いタイプ「KY-BR-WL100」なんですが、ファーム更新でUPnP対応していたんですね。WindowsXPってデフォルトではUPnPは無効になっているので、コントロールパネル〜プログラムの追加と削除〜Windowsコンポーネントの追加と削除〜ネットワークサービスで追加してやるとOS側も有効になります。ってことであっけなく完了・・・と思いきや・・・再起動するとUPnP自体はちゃんと機能している(ネットワークにルーターがちゃんと表示されている)ようなんですが・・・ どうもタスクトレイの様子が変。Win98時代からシステムリソースには随分悩まされたこともあり、未だに貧乏性でタスクトレイに並べるアイコンは極力少なくしているんですが・・・ どう見ても少なすぎる(^^;) いつもは・・・
こんな感じなんです。左から
Norton Internet Security 2004
Giga Pocket 予約マネージャー
Millenium G550 ユーティリティ

が・・・
こんな状態になってます(^^;)

ん〜・・・ タスクマネージャーで見るとNISも予約マネージャもちゃんと起動していますから(Gigaのタイマー予約も勿論OKです)、この状態でも全く問題は無いんですが・・・ 非常に嫌な感じです。多分ちょっとした起動周りの順番をいじれば回復するだろうと思ってスタートアップとかちょっと弄くってみたんですが、どうにもなりません。一度プロセスを終了させてから再度実行すればアイコンは復活するんですが・・・ どうにも起動時からちゃんと表示できません。まあ、実際ちょっとは原因がわからず悩んだんですが、UPnPを無効にするとあっさりアイコン復活。原因ははっきりしましたが・・・ 解決はしていません(t_t) う〜ん何かご存知の方いらっしゃいませんかねぇ・・・ まあ、特に困ったことは無いんですが・・・

ん、そういえばネットワーク接続の状況ってタスクトレイに表示してなかったなぁ・・・ ひょっとしたらこれに引っ張られてるのかも・・・

(2004.01.30 記載)
   

R60 グラボ交換以降発生 発生頻度:100% 危険度: 回避済
Win2000で、シャットダウン・休止状態に入ろうとするとexplorerが固まる。
グラボ交換後、なんとシャットダウン出来なくなってしまいました・・・ 正確に言うと、ユーティリティソフトが悪さをしているようで、シャットダウンしようとするとexplorerが固まります。で、その旨のダイアログで固まってしまうんですね。しかも、なぜか同じexplorerが2回?固まるらしく、ダイアログも2度出ます。「プログラムの終了」ダイアログが表示され、「すぐに終了」を押さないとシャットダウンできません。もちろん、シャットダウンばかりでなく休止状態にも満足に入れません。まあ、ダイアログさえ飛ばせば問題ないんですが、シャットダウン時に時間が掛かる(ダイアログが出るのにそれなりに時間が掛かる)上に、Gigaのタイマー録画にも支障がでますよねぇ・・・

ってことでユーティリティソフトから色々グラボ設定を変えてみたんですが、どうにも改善されません。ソフトはドライバと一緒にインストールされるようで、ドライバ単体での使用も出来ないようです。WEBから最新版をDLしてもNG・・・ 仕方が無いので方針を変更し、explorerが固まってもそのままシャットダウンできるように設定を変えてやることにしました。

実際には、定番のWin2000FAQさんを参照し、それに従ってレジストリの設定を変更してやりました。

1.HKEY_CURRENT_USER \Control Panel \Desktop を展開。
2.AutoEndTasks 文字列値をダブルクリックし、データに 1 を設定。


これでダイアログを飛ばし(実際には発生した瞬間に飛ばしてるんでしょうけどね)、シャットダウンや休止状態に入れるようになりました。ちょっと腑に落ちませんが、まあこれで通常使用に問題がありませんので、まあ良しとしましょうかねぇ(^^;)

(2003.03.01 記載)
   


R60 ダイヤルアップ接続?以降発生 発生頻度:80% 危険度:大? 解決済
Win2000で、休止状態から復帰出来ずにブルースクリーンになる。
結構致命的なトラブルです(T T) 単に「休止状態に入らなければいい」なんていう逃げもないことはないんですが、やはりそうもいきません。特にR60はGigaPocketでビデオデッキ代わりに使っていますので・・・ずっと電源入れっぱなしって訳にも・・・ ってことでまずは解決策から。

1.Livedoorのダイヤラーをアンインストールする。

以上(^^;)

っていうか、これには事情がありまして・・・

【伏線】
Livedoorは無料サービスが基本なんですが、いろいろな(大人の)事情により最近になって多くの点に変更が加えられています。このHPのURLが一度変更になったのもその影響なんですけどね。で、今回のトラブルの伏線としてまず、「無料ダイヤルアップ接続先(アクセスポイント)のTEL番号が全国統一の‘0570-037-037’になった」んです。さらに、WEBメールアカウントに関しても、「90日以上Livedoorのインターネット接続サービスを使用していない場合削除される場合がある」ことになりました。で、‘み’としては、このLivedoorのメールアドレスをあちこちに登録しているために簡単に使用を止める訳にもいかず、継続使用のために少なくとも3ヶ月に一度‘0570・・・’にダイヤルアップ接続することになりました。

【原因】
そこで、‘0570・・・’に接続するダイヤルアップを設定して接続したんですが、どうにも上手くいきません。ネットワークの状況を見る限りでは接続できているんですが、WEBページが表示できなかったりとか・・・で、Livedoorのサポートページにダイヤラーがあったので、これを使用してみました。以前(アクセスポイントが全国に点在していて、0570に統一される前ですね)はこのダイヤラーの古いバージョンを使用していましたから、特に問題意識はなかったんですね。んで、とりあえず接続して90日対策のアリバイを作りました。

【発生】
‘み’のGigaタイマー録画は、現在週末に偏っています。上記ダイヤラーのインストールは偶々週明けだったので、一週間休止状態を使用することもなくトラブルは表面化しませんでした。で、いざタイマー録画の段になって固まってたんですね〜(^^;) なお、最初単発の問題かと思っていたらほぼ確実(それでも80%程度なんですけどね・・・)に発生していました。100%でないのはやや気になるところですが・・・

【分析】
上では1行であっさりと書いていますが、実は結構悩みました(^^;) 原因であるダイヤラーのインストールから問題発生までほぼ一週間が経過していましたし、ブルースクリーンの文字かを解析して原因を特定するのはちょっと‘み’には無理・・・イベントログを見ても良くわかりません・・・「最近ずいぶんいろいろなソフトをインストールしたし、これはOSから再インストかなぁ」なんてやや覚悟を決めつつ、一応エラーの内容を見てみると・・・
DRIVER_IRQL_NOT_LESS_OR_EQUAL
Address BFEBFC2B base at BFEB6000

みたいな感じです。で、よーくメッセージを見ると「NDIS.sys」の文字がありました。これはNIC関連のシステムファイルのはず・・・大きなヒントです。ネットワークで何か変わったことをしたかと考えると上記ダイヤラーしかないんですね。で、アンインストールしてやったところ無事に解決しました(^o^) 今後、Livedoorへの接続はC1XGに任せることにしようと思っています(^^;)

【追記】
ブルースクリーンが発生したときには、今回のようにその文言から原因を特定できる「可能性」があります。OSの初期設定では「ブルースクリーン→即再起動」となっているはずですので、ブルースクリーンで止まるように設定を変えておきましょう。これをやっておかないと再起動とブルースクリーンを延々繰り返す無間地獄に落ちます(^^;)

マイコンピュータ〜プロパティ〜詳細タブ〜起動/回復〜「自動的に再起動する」のチェックをはずす

(2003.02.06記載)


【再発】
何度かGigaのタイマー録画テストをして問題がなかったので、治ったと思っていたらまた再発(T_T) その間特にソフトもハードも変更していないので、頻度が下がっただけで問題は解決していないようです(^^;) エラーメッセージの内容には変化がなかったので、やはり原因はネットワーク関連・・・ これはいよいよ根本的な解決が必要かもしれませんねぇ・・・

【完治】
多分・・・ですが、大丈夫かと思います。状況から判断するとネットワークデバイス辺りが怪しいので、この辺をきれいにしてやりました。

1.SmartConnectを削除する。
LANを組んで以来必要がなくなったので削除。合わせてデバイスマネージャー(ネットワークアダプタ)から SONY iLink Adapter(だったと思う)も削除。

2.無線LANカードのドライバ更新する
更新といっても当て直しただけで、バージョンなどは上がっていません。ただ、これによって自動設定されていたIRQ=03が、なぜか07に(やはり自動で)変更されました。もちろん03の時にも、更新後の07でも「競合はありません」と表示されてるんですけどね。

ってことでこれでなんとか無事に復旧したようです。
残っているネットワークアダプタは無線LANカードのものだけなので、まあこれ以上はきれいにならないでしょうしね(^^;)

(2003.02.09 記載)
   


R60 DVD+R/RW再生テスト以降発生 発生頻度:100% 危険度: 解決済
Win2000(SP2)で、FDDドライブが原因で休止状態に入れない。
Road to DVD! の【その3】で紹介しているように、RicohのDVD+R/RWドライブ「MP5125A」で作成
した
DVD+R/RWサンプルメディアの再生テストをやはりRicohのDVDコンボドライブ「MP9060A」で
行ったところ、それ以降休止状態に入れなくなってしまいました。
休止状態を選択すると、OSから「FDDのドライバが原因で休止状態に入れません。FDDのドライバを
更新することで解決出来る可能性があります」の様なエラーメッセージウィンドウが表示されて
しまいます。確かに休止状態に入ろうとするときにFDDにアクセスしているようです。それまでは
こんなアクセスはありませんでしたから・・・
というわけで、このメッセージ通りにFDDのドライバを更新したら無事に解決しました(^^;)
すぐ下のトラブルにあるように、FDDはフリーズトラブルを引き起こしたり(まあ、本当はサウンド
ボードドライバが悪いんですけどね)していたので、結構びくびくモノだったんですが、結果
オーライですね(^o^)   (2002.07.23 記載)
   


R60 サウンドボードベータドライバ導入以降発生 発生頻度:100% 危険度:大? 解決済
Win2000(SP1)でFDにアクセスすると、その瞬間にフリーズする。

Gigaのアンサポートドライバが供給されたことにより、Win2000でもスタンバイができるようになったR60。
喜んでいたのも束の間、気がつけばスタンバイからの復帰後には音が出ません・・・ まあ、これ自体は
最初からVCLにもアップされていましたので、まあ、我慢するしかないなあ、なんて思っていたのですが、
なんとタイミング良くこの問題を回避するドライバが発見されました。このあたりの成り行きはこのHP内
‘アンサポートドライバ検証’を見ていただけるとばっちりなのですが、なんとこのドライバ導入後、FD
にアクセスしようとするとフリーズする、という報告を同様にドライバを導入した何人かの方々から頂きま
した。この時点では‘み’のR60では問題も発生していなかったのですが、数度目のFD使用時に同じ
トラブルが降臨(!?)されました・・・ 以降は100%確実にFDにアクセスする度フリーズします(T_T)
ちなみに空のFDドライブなら大丈夫だったりしますが・・・ なお、このトラブルは同じドライバを使用した
にもかかわらず発生していない人もいます。全く原因不明です。
セーフモードやDOS上など(Win98デュアルブートの方の98側も含む)では正常に動作するので、ハード
的な問題ではないことも加筆しておきます。
参考までに、‘み’を含めてトラぶった方が解決を期待して施した‘手’を下に列挙します。

1.FDドライバの更新
2.DirectXの更新(7.0→8.0a)
3.Win2000 ServicePack2 の導入
4.ウィルスチェッカーのFD常時チェック解除

・・・と言うわけでこれらは皆効果なしです。では実際にFDを使わざるを得ない場合、どうすれば
いいのでしょうか・・・?
 非常に面倒くさいのですが、どうにもならない訳でもありません。

1.デバイスマネージャからサウンドボードを使用不可にして再起動する。
2.Win98デュアルブートなどの環境があるなら、こちらで再起動する。
3.外付けFDDを使用する。

これで一応OKです。1.はこのトラブルの原因をまさに特定しているってことですね。それを取り除い
てしまえばいいのです。2.は上でも書きましたが、ソフト的な問題なのでOSを代えてしまえば万事
OKです(って解決してないんですけど・・・)。盲点なのは3.です。‘み’の場合はC1XG用に所有して
いたUSB接続の‘PCGA-UFD5’を試してみたんですが、Bドライブとして正常に認識され、動作もOK
でした。でもこれって、結局は問題を回避しているだけで解決には至っていないんですよね・・・
現状では
‘スタンバイ復帰後のサウンド機能’or‘FDDの正常動作’の二者択一
になってしまっていますから。

SONYさんが正式なサウンドボードドライバを提供してくれるのを待つしかないんでしょうかねえ(^^;)

・・・さて、やっとのことでこのトラブルの回避方法が見つかりました!!詳しくはこの
HP内の
‘アンサポートドライバ検証’を見ていただけるとOKです。βドライバからの復帰方法を記載しました。

ドライバを変更することでトラブルを回避しています。ただ、ひとつ気がかりなのが、Gigaの音声が
やたら大きく聞こえるんです。勿論オーディオのプロパティ(AuxiliaryがGigaと連動しています)でも
調整はできるんですが、それを差し引いてもまだ大きい感じです。まあ、FDDフリーズトラブルよりは
全然ましなんですけどね(^^;) (2001.09.26 加筆)


R60 かなり初期から発生 発生頻度:20% 危険度:特大 未解決
OS(Win98Se)起動時に勝手に再起動される。
原因不明です。OS起動画面から左上にアンダーバーが表示されるだけの画面になり(ここまでは
通常どおり)、ディスプレイに画像が表示される瞬間になって、表示の代わりにぷつっと落ちます。
その結果自動的にSONYロゴ画面から再起動され、気が付かないでいるとそのままSafeModeへ
直行です・・・

なななんと、このトラブルが致命傷になってしまうとは〜
HDDクラッシュ?を引き起こしてしまったんです!!

Win98Se&W2Kデュアルブートにしていた時はW2Kをメインに使っていたので、このトラブルの存在
自体を忘れていたんですが、WinCDRトラブルによってWin98Seに戻った時に当然の如く再発病〜
ってことはハードウェアの問題ではないですよねえ。
まあ、仕方がないので末永くつきあっていこうとしていた矢先、なんと!!
DOS画面が文字化けしているような画面が現れ、PC自体がブートとしなくなってしまいました・・・
ことの顛末は以下の通りです。

1.ディスプレイの主電源を入れずにR60の電源スイッチオン(時間短縮のためですね)。
2.勝手にリブート病発生(ビープ音が鳴るのでわかるんですよ〜)。
3.ディスプレイの電源をつけると、画面にはDOS画面が文字化けしたような黒バックに白字の不審な
  文字が数行写っていました。不審な文字はアラビア文字というか古代文字というか、そんな感じ
です。
  エンターキーをたたくと‘A:¥>’が文字化けしたような部分が改行されるので、まずDOS画面の
  文字化けと見て間違いなさそうです。どうにもならないので強制的にPCの電源OFF。
4.再起動するとスキャンディスクが走ります。が、特定の場所でフリーズ・・・ 
  なんと何度やっても同じ場所でフリーズ・・・ 
  Safeモードでもやはりスキャンディスクが走ってフリーズ・・・
  起動FDからブートしてスキャンディスク掛けてもやはりフリーズ・・・
  こ、これはHDDクラッシュかあ〜!!
5.泣く泣くHDDを交換して復旧。この時点では単純に物理的なクラッシュだと思っているので、勝手に
  リブート病と関連があるとは夢にも思わず・・・ちなみに逝ってしまわれたのはR60パワーアップ編7
  で紹介している30Gの
Seagate製 BarracudaATA ST328040Aです。元々オークションで
  買ったモノだし、まあ諦めるしかないか、位に思っていたんですが・・・
6.なんと数日後、これまたR60パワーアップ編6で紹介している、
Maxtor製 96147H6が同じトラ
  ブルで逝ってしまいました!!この時起動HDDとして使用し始めたばかりだし、いくら何でもこれは
  おかしいだろう、ということで、取り敢えずHDDをフォーマットしてみることにしました。
7.フォーマット結果は・・・ あっさりOKでした(^_^)v フォーマット後は上記どちらのHDDも問題なく使
  用できました。しかもそのHDD、Win98se上でスキャンディスクを走らせてみると、不良セクタどころ
  かエラーすら無いんです。これは一体どういうこと・・・? 
8.上記の2つのHDDに発生した悲劇の共通点を考えると、ディスプレイの電源を落としていたこと&
  勝手にリブート病が発生したこと、が挙げられます。っていうかそれ以外にはないんですよねえ。
  ・・・この先は推測でしかないのですが、状況を整理するとおおよそこんな感じではないでしょうか・・・
  勝手にリブート病により再起動がかかった時、ディスプレイの電源が入っていないと、OSは接続され
  ているディスプレイを再認識できない。この為、不完全もしくは不適切なディスプレイドライバがインス
  トールされてしまい、本来表示されるべきDOS画面の文字化けが発生する。加えて、ここで強制的に
  電源をOFFにせざるを得なくなるため、次回起動時にスキャンディスクが走る(あ、これ走らないよう
    に設定変えておけば良かったのかも・・・)。しかし、実際には問題が起きていないため、エラーがある
    筈の場所にエラーが無く、フリーズしてしまう・・・ってことでどうでしょうか?
9.ってことで、現在はW2K単独ブートでR60を使用しているので、この病気は(治っていませんが)回避
  しています。
  最後に教訓・・・ 
           起動時のアラビア(古代)文字は要注意!!  &  バックアップは大切です!!
          
   

R60 ATAボード増設以降発生 発生頻度:100% 危険度:小 解決済
PCカードスロット接続のスマートメディアアダプターがプラグアンドプレイで認識しない。
PCカードスロットに挿入するスマートメディア用のPCカードアダプター(オリンパス製)が、プラグアンド
プレイで使用できなくなりました。通常であればカードを挿すとHDDが増えたようにR60が認識し、
エクスプローラ等でファイル操作が可能なんですが、PCカード自体は認識されるもののドライブが
見えない状態で全く操作できません。
例外的に電源OFFの状態でPCカードを指していた場合には通常どおり認識・操作できるのですが
この時にはカードを外せなくなります(このデバイスは取り外せませんって言われます)。

実は
サイバリオンさんの掲示板で皆さんにレスを頂き、解決する事が出来ました。
皆さんありがとうございます!!

・・・結果的に、IRQの競合(?)が原因でPCカード内スマートメディアを認識していませんでした。
今回ATAボードを増設したため、ATAボード用にIRQが消費され、今までPCカード用に使用されて
いたIRQを占有してしまったようです。
起動時から接続してSMを認識しているときはIRQ14がPCカード用に使われていましたが、プラグ
アンドプレイでPCカードを挿し込んだ場合はIRQを使用することができないでいるようでした。
個々のデバイスのプロパティを確認するとPCカードのそれには‘割り込み要求’が設定されていません
でしたからね。
代わりにIRQ14はマザーボードのプライマリIDEコントローラが使用していました。
(通常ではこの設定でOKなようです)
つまり、現在使用していないマザーボードのプライマリコントロールのためにPCカードの入り込む余地が
無くなってしまっているということです。ということは、これを停止してやれば問題は解決するはずですね。
なお、IRQの使用状況は‘マイコンピュータ〜プロパティ〜デバイスマネージャ〜コンピュータ〜
プロパティ’で確認できます(変更はここではできませんが)。

マイコンピュータ〜プロパティ〜デバイスマネージャ〜ハードディスクコントローラ〜
Intel 82371 AB/EB PCI Bus Master IDE Controller 〜プロパティ〜設定 で
`デュアルIDEチャネルの設定’ を‘既定値’から`セカンダリIDEチャネルだけを使用可能にする’に
変更する。再起動要求があるので再起動。

これでOKです。でもこれって、マザーボードのプライマリIDE接続を(OS上では)止めてしまっている
ことになるはずなので、今後HDDをマザーボードのプライマリには接続できませんね・・・
あと、一つ気になったのはIRQ(1〜15しかない)って基本的に番号が重なってもOSが適切に制御して
くれるはずなんですけどね・・・

 

R60 周辺機器増設に伴い発生 発生頻度:50% 危険度:小 解決済
OS(Win98Se)起動時にブルースクリーンが出て‘オーバーフローの為・・・’と警告される。
Windows98.FAQ - ウィンドウズ処方箋さんに従ってMinSPS の値を増やしたところ、
あっさりと解決しました。Win98FAQさん、ありがとうございます。
簡単に手順を書いておきます。

[ファイル名を指定して実行] から System.ini を起動。
[386Enh] と書かれた行を探し、この行の下に次のような行を挿入。
MinSPs=4 (大文字小文字の区別あり)
メモ帳を閉じて Windows を再起動。
MinSPS が特に設定されていない場合の標準値は 2。
4 に増やしても症状が継続する場合は、6 や 8 に増やす。

なお、このトラブルはドライバが使用するスタック領域が不足すると起こるそうです。
我ながら色々増設しましたからね・・・R60の後側はコード地獄のようです。